Forum Index | Search the Forum | Register | Login

HOME  |  FORUM  |  GALLERY  |  DOWNLOADS  |  TEST  |  CONTACT  |  LEGAL


1.9 Bug With Shaders

Having problems running Chroma Hills? Having a server issue and need advice? Post in here.

Moderator: Panja

1.9 Bug With Shaders

Postby Shivaxi » Sat Mar 26, 2016 3:54 am

I noticed that with the new 1.9 Chroma Hills Texturepack, there seems to be a bug when it comes to running them with shaders and normal map/bump mapping. See what I mean:

Image

Creates these weird lines between each block, like they're not connecting correctly. If I try turning on connected textures in optifine, normal map/bump mapping is disabled entirely on most textures. But if I use the old 1.0.8 texture pack originally designed for SEUS shaders, this problem goes away, as you see here:

Image

Of course then I'm missing out on all the good 1.9 stuff. So far it seems normal map is broken with any stone or wood textures, also wool and dirt...but that's all I've tested so far.

Image

Also leaves are not translucent in the 1.9 texturepack version, but are translucent if using the old 1.0.8 version

Image
Shivaxi
 
Posts: 18
Joined: Sat Jan 02, 2016 6:27 am

Re: 1.9 Bug With Shaders

Postby Shivaxi » Sat Mar 26, 2016 5:03 am

funny little development...removing the clock and compass png texture files from the \assets\minecraft\textures\items folder seems to mostly fix this weird normal map problem...i can't explain that haha...still not 100% though, but I tried adding those clock and compass textures to the old 1.0.8 version I have, and it broke the texture pack in the same way....very strange
Shivaxi
 
Posts: 18
Joined: Sat Jan 02, 2016 6:27 am

Re: 1.9 Bug With Shaders

Postby Ditchy87 » Sat Mar 26, 2016 7:44 am

That is most certainly a strange issue Shivaxi.

What shaders are you using? as personally I'm using Sildurs and having no texture issues but when I switch to Seus's all hell breaks loose xD
Lead Builder For Chromahills/Clans of Chroma
User avatar
Ditchy87
 
Posts: 126
Joined: Sat Apr 13, 2013 11:06 am

Re: 1.9 Bug With Shaders

Postby Shivaxi » Sat Mar 26, 2016 2:03 pm

The bug happens when using either SEUS or Continuum, both which support Normal Map / Bump Mapping
Shivaxi
 
Posts: 18
Joined: Sat Jan 02, 2016 6:27 am

Re: 1.9 Bug With Shaders

Postby Ditchy87 » Sat Mar 26, 2016 5:33 pm

Yeah Seus's shaders isn't playing well with Chromahills right now, whether that is to do with the 1.9 update or the weird issue that caused some textures to get flipped maybe throwing off the normal/bump maps resulting in the weird errors were seeing.
I know Syclone has fixed most so if you haven't downloaded the updated 1.9 pack since its initial release try that first.

Otherwise I recommend trying out Sildurs shaders for now until we can pinpoint where the problems are.
Lead Builder For Chromahills/Clans of Chroma
User avatar
Ditchy87
 
Posts: 126
Joined: Sat Apr 13, 2013 11:06 am

Re: 1.9 Bug With Shaders

Postby Shivaxi » Sun Mar 27, 2016 3:23 am

Ditchy87 wrote:Yeah Seus's shaders isn't playing well with Chromahills right now, whether that is to do with the 1.9 update or the weird issue that caused some textures to get flipped maybe throwing off the normal/bump maps resulting in the weird errors were seeing.
I know Syclone has fixed most so if you haven't downloaded the updated 1.9 pack since its initial release try that first.

Otherwise I recommend trying out Sildurs shaders for now until we can pinpoint where the problems are.


Alright I'll try that, but yeah as I said, using the old v1.0.8 CH textures, bump mapping works perfectly fine with those textures in Minecraft 1.9 with Optifine, and deleting those compass and clock textures seems to help strangely, so maybe something conflicting is all I can think of cause I don't know how else to explain that.

(Also, I was checking for updates, but was looking at the version number instead of the date uploaded, so I didn't realize there was an update since the version number was still v.1, may wanna change that to v.2 to avoid confusion lol)

EDIT:

Tried new version, still the same issue. Tried sildurs shaders but it doesn't support bump mapping / normal map, so textures are just flat

EDIT 2:

New interesting development...removing the ITEMS folder in "ChromaHills128x-1.9-v.1.zip\assets\minecraft\textures" pretty much completely fixes bump mapping, as shown here:

Image

The only issue is with grass blocks on the bottom it looks like:

Image

So yeah, definitely seems like some sort of conflicting error
Shivaxi
 
Posts: 18
Joined: Sat Jan 02, 2016 6:27 am

Re: 1.9 Bug With Shaders

Postby Shivaxi » Sun Mar 27, 2016 5:10 am

Okay, just did a bunch of testing, adding textures back slowly into the ITEMS folder again to see when and which files would break it. Adding either the clock .png's or compass .png's definitely seems to break it, more so the compass, as this happens:

Image

However, once I got to a certain point, it seems if the file count goes over 117 files in the ITEMS folder, than it will always break, it doesn't matter what texture .png's are in there...so now it seems like some sort of limit with how many textures it can have or something. It's possible that deleting any number of files, even outside of the ITEMS folder, may have fixed the bump mapping / normal mapping issue. This would explain why the bug doesnt happen in v1.0.8 because there weren't as many textures as there are in 1.9
Shivaxi
 
Posts: 18
Joined: Sat Jan 02, 2016 6:27 am

Re: 1.9 Bug With Shaders

Postby SycloneSJS » Mon Mar 28, 2016 11:28 pm

Thats a very interesting yet odd find right there!

Hmm Mojang stupidly put all the clock and compass frames into single images for 1.9, totally bonkers choice for game development and optimization....*sighs*
User avatar
SycloneSJS
 
Posts: 531
Joined: Wed Mar 20, 2013 3:03 pm

Re: 1.9 Bug With Shaders

Postby Shivaxi » Tue Mar 29, 2016 1:40 am

Another interesting development. I figured out thatThe reason the Compass textures break bump mapping so bad is because they are all 192x192 instead of 128x128. If I convert the textures to 128x128, the problem gets fixed. I tried converting just one texture to 256x256 and the bump mapping broke insanely again...so it apparently doesn't like anything above 128x128.

Now the bump mapping will still slightly be broken, just not as bad as when it has 192x192 compass textures...it's like there's 2 versions of broken for the bump mapping, the compass broken version is the picture before i showed, showing all the criss cross cuts in every texture and block...the normal broken is the bump mapping not aligning up right at the edge of a texture/block which i also showed a picture of before.

So to fix the mis-alignment issue, it seems I can't have more than 145 textures in the ITEMS folder. As soon as I try adding the rest of the textures back, any single one, and its at 146 or more in that folder, the bump mapping breaks again. I noticed however that a way around this is by converting some of the item textures from 128x128 to 64x64, and then I can have more than 145 textures in the Items folder...its very weird...the Items folder also seems to be linked to the Block textures folder? as in like, if i delete 1 texture from the Blocks folder, than I free up a space for the Items folder, allowing me to have 146 instead of 145 textures in the Items folder...deleting any of the other folders has no effect whatsoever.

EDIT:

Forgot to mention that I also tried splitting up the resource pack into multiple resource packs...that did not work lol, still got the bump mapping bug

EDIT 2: While I'm at it, I suppose I should report that Redstone Dust isn't working correctly in the CH 1.9 texture pack, and instead shows the original redstone dust trail when placing on the ground. And also a bit of a request, it'd be nice if you added the slider back in the menu for things like draw distance and FOV and stuff...it's a little annoying not having it there haha...just personal taste though
Shivaxi
 
Posts: 18
Joined: Sat Jan 02, 2016 6:27 am

Re: 1.9 Bug With Shaders

Postby Shivaxi » Tue Mar 29, 2016 3:32 am

Here, I fixed the Redstone Dust, hope you don't mind:

https://www.dropbox.com/s/e3nk7kxxr95c5 ... x.zip?dl=1

Copy those files into the "ChromaHills128x-1.9-v.1.zip\assets\minecraft\textures\blocks\" directory. Just needed a little renaming, and the line dust texture had to be rotated 90 degrees. I also made a dust dot texture based on the original dust cross texture, and then shrank it a bit to fit the size of the line, otherwise connected redstone dust that turned or crossed looked a little weird.
Shivaxi
 
Posts: 18
Joined: Sat Jan 02, 2016 6:27 am

Next

Return to Pack Support / Bug Reporting

Who is online

Users browsing this forum: No registered users and 1 guest



© 2014 Chroma Hills. Chromahills.com is the official website of the Chroma Hills texture pack and all things created under the Chroma Hills brand name for Minecraft by SycloneSJS. Chromahills.com is not affiliated with Mojang. All content on this site is protected under international copyright law with trademarks pending. Powered by phpBB © phpBB Group
Site and Hosting by 28 Studios